[MSX] uzix dosdir etc.

Adriano Camargo Rodrigues da Cunha msx@stack.nl
Tue Apr 8 22:37:01 2003


> > dosdir /dev/fd0 should work. dosdir a: also should work.
> They both do not. Uzix returns dosdir: cannot open /dev/fd0: No such device or 
> address (there is a floppy in the drive, and ls /dev returns a.o. /dev/fd0)

Strange... Are you logging as root or ordinary user? How many disk drives do
you have? What is your MSX machine?

> mount /dev/fd0 /floppy gives the same error. /floppy does exist.

Do you have a /floppy directory created?

> Another thing: I downloaded the Hitech C cross compiler for MSX DOS to try 
> some UZIX programming, but the stdio.h is missing. Where can I find it?

It's in the HTC (CPM) package. You must download both packages, and
overwrite the CPM package with MSXDOS package.

> And 
> where can I find some documentation that is in English?

In the HTC package there is a readme.txt file.

> Yet another thing: when I try to copy for instance command2.com from partition 
> 0 to /tmp using
> dosread /dev/hda0 command2.com /tmp/command2.com
> dosread complains: not enough memory for FAT cache, and only copies some 8K of 
> the file to /tmp. But I have 1024 KB memory in slot 3.2 and a swap file of 
> 944K. Does dosread only use a part of that? 

Weird...
1) You're using UZIX 0.2.x , right?
2) Is your partition 0 FAT12 or FAT16?
3) I tested dosread even with 32MB partitions and everything worked fine.
4) UZIX doesn't use a swap file... So, what's this 944kb file? :) Where did you
find it?
5) 1024KB memory doesn't means that your UZIX application can use it. Each
application has a userspace of maximum 48k in UZIX 0.2.0 (32k in UZIX 1.0).


Adriano Camargo Rodrigues da Cunha         (adriano@alsoftware.com.br)
http://www.alsoftware.com.br/adrianpage/

* As opinioes expressas neste e-mail sao de minha inteira
  responsabilidade e nao refletem a posicao da A&L Software *